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! !
TOPCAT Tutorial !

(developed by TOPCAT's author Mark Taylor) !
Uses Aladin, TOPCAT and SPLAT-VO !

Working with tables is the everyday activity of many researchers. TOPCAT does what you 
want with tables, and it does so closely integrated into the VO. From sorting to crossmatches, 
from histograms to density plots, TOPCAT is the swiss army knife of data manipulation and 
visualization. This tutorial will show you how you can do more with your tables and the VO 
using TOPCAT and it's connection to other VO tools. !
Basic Usage: Tables, Data and Metadata 
Getting Started !

• Start TOPCAT (click on a jar file), or from the command line type  
    
       topcat 

     

or  
    java -jar topcat-full.jar 
     

or maybe  !
    topcat -Xmx512M 
    java -Xmx512M -jar topcat-full.jar 
     

Control Window 
• Use the Help window ( ! ). Search for a topic by entering words in the Find box. 

Other help options are in the Help menu. Or, read the manual from the TOPCAT web 
page. 

• Load an example table:  

o Open load window ( ! ) 
o Use Examples|Load Example Table menu item (this will load e.g. 

6dfgs_mini.xml.bz2; an example table for demo usage cut-down from the 6df 
Galaxy Survey, some values are faked!) 

• Hover over toolbar buttons to see tool tips.  
• Click on menu bar and move over each menu to see available options. Note that some 

of these appear in the toolbar and others don't.  
• Examine basic table metadata in Control Window (Label, Name, Row count, Column 

count)  
• Edit the Label  !

Table Views 
Look at basic table data and metadata by using the items in the Views menu (or equivalent 
toolbar buttons). Choose a table with some metadata, e.g. the example table 6dfgs_mini (from 
Examples|Load Example Table menu in Load Window). Other FITS or VOTable tables 

http://www.star.bris.ac.uk/~mbt/topcat/
http://aladin.u-strasbg.fr/
http://www.star.bris.ac.uk/~mbt/topcat/
http://star-www.dur.ac.uk/~pdraper/splat/splat-vo/
http://www.star.bris.ac.uk/~mbt/topcat/
http://www.starlink.ac.uk/topcat/topcat-full.jar
http://www.starlink.ac.uk/topcat/topcat-full.jar
http://www.star.bris.ac.uk/~mbt/topcat/sun253/index.html
http://www.star.bris.ac.uk/~mbt/topcat/
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!
(especially from Virtual Observatory sources) may have useful metadata; ASCII and CSV 
tables probably will not.  !!
! Data View 

• Scroll around 
• Move columns by dragging on column headers 
• Edit table data by double-clicking on cells 
• Sort by column by right-clicking on column in the table 

! Table Parameters (per-table metadata) 
• See metadata items. 
• Click on a row to see more detail. 
• Edit parameters by selecting them and changing the values in the detail panel below 
• Add and remove parameters using ! and ! . 

! Column Metadata 
• Open data viewer window ( ! ) at the same time 
• Hide all columns ( ! ) - see them disappear from the data viewer. 
• Select ones you're interested in by clicking the checkboxes in the Table columns - see 

them reappear in the data viewer. 
• Add a new column ( ! ) - e.g. Name=B_R  

o Name = B_R  
o Expression = BMAG - RMAG  
o Units = mag (optional) 

See the column appear in the columns window, and the data viewer. 
• Edit the expression by double-clicking on it in the Expression column 
• see all available functions in Functions → Syntax Help or press the f(x) button  
• Add new sky coordinate columns ( ! )  

o Select input System, Units and coordinate RA/Dec columns (e.g. ICRS, 
degrees, RA2000, DEC2000) 

o Select output System and Units  
o Either accept or edit suggested output column names 
o Click OK  
o See new columns appear in Column and Data Viewer windows 

! Table Subsets (row selections) 
Use a table with some metadata, e.g. the example table 6dfgs_mini (from Examples|Load 
Example Table menu in Load Window).  

• View existing subsets, see how many rows they contain (Size). These (if any) 
correspond to boolean (true/false) columns in the table as loaded; true values are 
included in the subset and false ones are not. 

• Add a subset ( ! )  
o Fill in the Subset Name field (e.g. blue_objs) 
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!
o Fill in the Expression field with an expression based on column names that 

evaluates to true or false (e.g. BMAG - RMAG < -1) 
o See how many objects are in it (Size/Fraction columns in window) 
o Edit expression by double-clicking it 
o Add a new subset that is the inverse of the one you've added: select its row in 

the display, then click !  !!
! Table Statistics 

• See Mean, Standard Deviation, Minimum, Maximum etc. 
• Select other univariate stats from the Display menu 
• Use the Subset for calculations selector at the button of the window to choose which 

subsets are calculated for !
Apparent Table 

• Back in the main Control Window, select a Row Subset which is not All. Note the 
Rows indicator shows Apparent rows accordingly.  

• Make sure some columns are hidden in the Column Window. Note the Columns 
indicator shows Apparent columns accordingly.  

• Select the Sort Order to sort the columns by a given column.  
• Look at the table in the Data Viewer - only the selected rows and columns are there, in 

the selected order.  
• If you Save the table now, that is what will get saved.  
• Duplicate the table using the File|Duplicate Table menu item. This is equivalent to 

saving the table and reloading it. Non-apparent rows and columns have disappeared in 
this copy.  !

! Load Window 
• Open the Load Window !  
• Look at the different toolbar buttons - lots of places to load a table from 
• Try a normal file browser to look for tables on your local filesystem.  

o ! Filestore Browser usually suitable  

o ! System Browser may be preferred for MacOS/Windows  
o Format selector:  

▪ (auto) is OK for FITS and VOTable files 
▪ Need to select explicitly for ASCII, CSV, etc 

• Pin the window ! if you don't want it to close when you've loaded a table.  
• Or, type a URL or filename into the Location field, e.g.:     ../data/messier.xml 
• Or, cut'n'paste a URL or filename onto the Table List in the Control Window.  
• To load multiple files from the same place, pin the window open, and double-click on 

the ones you want.  
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!
• ! Hierarchical browser can look inside tar files, zip files, Multi-Extension FITS, 

multi-table VOTables, etc. If you have suitable files on your disk investigate them; 
otherwise try the Examples|Brows Demo Data menu item.  

• ! VizieR load dialog can download data directly from VizieR.  
o If window is too tall for your screen, resize it and use the File|Scrollable 

option (present on all windows)  
o Load a catalogue for an object class of your choice:  

▪ Check All Rows radio button 
▪ In the Catalogue Selection section choose By Keyword tab 
▪ Enter your favorite object class  in the Keywords field (e.g. „white 

dwarf“, „quasar“ or „blue straggler“) !
▪ Click Search Catalogues button 
▪ Select first row (B/sn) 
▪ Click the OK button at the button 
▪ Table loads in TOPCAT 

o Search for 2MASS extended sources:  
1. Click Cone Selection radio button 
2. Enter your favourite object name 
3. Click Resolve to get coordinates - RA and Dec fields are filled in 
4. Enter a suitable radius (1 degree?) make sure units selector is set 
correctly 
5. Click Surveys in catalog selection below 
6. Select 2MASX (The 2MASS Extended Source Catalogue) and click OK 
7. Table loads in TOPCAT !!

! Save Window 
• Select a table in the Control Window table list, open save window !  
• Use Filestore Browser ! or System Browser ! to save it. 
• Choose an output format:  

o If in doubt, choose FITS (most efficient, stores metadata) 
o ASCII/CSV is OK if you want to process with other software 
o Various other options are available ... see the manual for details 
o TOPCAT will choose a sensible format if you use a well-known file extension 

like ".fits", ".csv", ".txt" 
o save one of the above tables as text table, ascii or csv format 

• To save multiple tables in one file, use Multiple Tables tab (FITS/VOTable only) 
• To save session, use Save Session tab; this saves subsets and hidden columns, not just 

apparent tables !
Plotting 

• Open Scatter Plot  !  or Plane Plot  
• Do a colour-magnitude plot for table 6dfgs_mini:  

http://www.star.bris.ac.uk/~mbt/topcat/
http://www.star.bris.ac.uk/~mbt/topcat/sun253/outformats.html


!5

!
o X Axis BMAG-RMAG, Y Axis RMAG, select Flip checkbox for Y axis in Axes -> 

Coords. 
o Plot and unplot different subsets by ticking the Subsets tab in plot window 
o Use different plotting styles (click on plot symbols in Row Subsets panel, and/

or Marker Style menu 
o Add error bars ( !  and/or ! , in Form tab) 
o Change error styles (click on plot symbols in Row Subsets panel, and/or 

Global Style Error Bar menu 

o Make a new subset by selecting some of the points in the plot (click ! ; drag 

out a region or regions, click ! again) !
o Experiment with Auxiliary Axes ( ! ) !!!
o Try adding text labels ( ! ) 
o Try the other plot types and options therein; some example tables are here.  !

▪ Histogramm, Plane Plot, Sky Plot, Cube Plot or Sphere Plot !
 old plot options: 

▪ ! histogram (try weighting values ! ) 

▪ ! Cartesian 3d plot 

▪ ! Spherical 3d plot (try adding radial coords ! ) 

▪ ! Stacked line plot 

▪ ! Density plot (needs a large data set) 
▪ save some of the plots as pdf, gif or fits (density plot) !!!

http://andromeda.star.bris.ac.uk/topcat/data/
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!  !!!!!!
Exercise 1: Pleiades 
(Credit: Niall Deacon, Hawaii)  

• Open the VizieR load dialog ( ! ) 
• Search for all the objects within 3 degrees of the Pleiades in the Tycho-2 catalogue:  

o Check Cone Selection button 
o Object name Pleiades, Resolve  
o Radius 3 degrees 
o Catalogue Selection Surveys tab 
o Click on row Tycho-2 (Name column is ordered alphabetically) 
o Click OK  
o Loads 3 tables - pick the one with most rows !
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!!
• Visualise proper motions:  

o Open a Plane Plot window  
o X = pmRA, Y = pmDE 
o Zoom in to find a cluster with non-zero motion 

o Draw a blob round it to create a new subset (click ! ; drag out the cluster 

region, click ! again) 
• Draw colour-magnitude diagram:  

o Open a different Plane Plot window 
o X = VTmag - BTmag, Y = VTmag, flip Y 
o See where the new cluster subset you identified sits in colour-magnitude space 

(main sequence?). If there are outliers, click on them to see their location in the 
proper motion plot.  

• Save the cluster identification:  

o Go to the Subsets window !  
o Select the row corresponding to the cluster subset 
o Create a new boolean table corresponding to this subset by clicking the To 

Column ! toolbar button 
o Save the table. !

 !
Exercise 2: Pleiades revisited !
Examine some other colours for the Pleiades cluster you identified in the previous exercise.  

• Reload the table from the previous exercise. 
• Select the cluster subset as the Current Row Subset in the Control Window. This will 

have the effect that subsequent matches only operate on these objects. 
• Go back to the VizieR load window ! , query a catalogue with different photometry 

in the same region (e.g. 2MASS-PSC) 
• Crossmatch the (now subsetted) Tycho-2 catalogue with this new catalogue ! . You 

probably want Algorithm Sky with a suitable Max Error, and Match Selection Best 
Match, but if the resolutions of the different catalogues are significantly different, 
some other choice might be appropriate. !!

• Visualise the positions of the crossmatch by overplotting the three sets of positions in 
the Sphere Plot window :  

1. Input cluster positions 
2. Positions loaded from VizieR catalogue(s) 
3. Results of crossmatch 

Overplot multiple data sets using ! use MarkerStyle menu to chose suitable symbol 
sets. Check the results look sensible.  
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!
• Using the resulting cross-matched table, do a different colour magnitude diagram of 

the cluster objects. See the crossmatch objects in the main sequence. !
 !
Exercise 3: Multiple Simple Spectral Access Query 
(expanded by Janine Fohlmeister)  

• Get the Asiago catalogue of supernovae from the Vizier load window ! - click the 
All Rows radio button, search for "supernovae asiago" in the By Keyword tab, select 
"B/sn" and hit OK. 

• Look at the table ! - observe the Type column. 
• Create a new subset in the Subsets window ! -  
 Name = 'type2',  Expression = 'startsWith(type, "II")'. 
• Set this subset as the current Row Subset in the control window; this means that 

subsequent operations like the multi-SSA query will only operate on that subset. 
• Do an SSA multicone query ! from the VO or Joins menus on the main control 

window. Select a service (registry euro-vo.org), e.g. HST Spectra (either search by 
Keywords for "hst" or similar, or just find it in the list of services that appears 
automatically, perhaps by sorting the list which you can do by clicking on the 
appropriate column headers). !

• When you've clicked the service, fill in the parameters at the button of the window: 
Input Table is the SN catalogue, and make sure the RA and Dec selectors are filled in 
appropriately. Set Search Radius to 100 arcsec. (in case: set Error Handling: ignore) !

• Hit Go and wait (see progress at the bottom of the search window – you might get a 
coffee meanwhile) for it to announce that it's added a new table. This is a table of all 
the HST spectra for type II supernovae from the B/sn catalogue. !

• Work out the age of each supernova when the spectrum was taken. Add a new column 

"obs_age" ( !  in ! window) with this expression:  
mjdToDecYear(isoToMjd(obs_start_time)) - (parseInt(substring(SN, 0, 4))) 

(see the functions window ! for documentation). Note however this is only 
approximate, since the catalogue only gives you the observational date and the year of 
the supernova designation. !

• Therefor create a new subset with obs_age>=0. (what is the unit of obs_age?) 

• Plot them on a sky plot - colour them by age ! and label them by ID, SN or target of 

the spectrum ! . !
• Start up a spectrum viewer such as SPLAT (here is a link for splat WebStart; for the 

full documentation click here). 
• Make sure a SAMP hub is running ! , ! . Observe in the control window that 

TOPCAT can see SPLAT !  !

http://star-www.dur.ac.uk/~pdraper/splat/splat-vo/
http://astro.dur.ac.uk/~pdraper/starjava/splat.jnlp


!9

!
• Set an Activation Action for the SN spectra table; click the Activation Action button 

in the control window, select View URL as Spectrum. Ensure that the Spectrum 
Location Column is filled in as the column which contains the spectrum URL 
(TOPCAT should fill this in automatically from examining column UTypes/UCDs - 
it's AcRef for the ST-ECF/HST/SSA service). You must then hit the OK button at the 
button of the window. !

• Click on one of the points in the spherical plot. It will cause the corresponding 
spectrum to be displayed in SPLAT. !

• Display some of the spectra in  SPLAT. The names of the spectra appear under 
“Global list of spectra”, note that cone search gives also spectral results for host 
galaxies or other objects whithin the search radius.    !

• Move over each button in the menu to see available options. 

• See table view !  in TOPCAT for wavelength and target information.  !
• In  SPLAT double click on a spectrum or highlight several and display them in one 

plot using the !  button. You can change the colour and appearance of the spectra 
either by clicking !  (random choice of colours) or modifying the Properties of 

current spectra. Click the !   button to see an animation of all loaded spectra.  !
• For a spectrum of your choice  (e.g. SN1987A) perform a polynomial line fit: click 
! , choose the degree of the polynomial, click the Add button and drag the mouse in 
the display window to select the range you want to fit, then press Fit. !

• The polynomial fit appears in the plot and under the Global list of spectra of the main 
SPLAT window. 

  
• You can Add, Subtract, Devide or Multiply your spectrum with the polynomial fit by 

clicking the !  button (try it!), this generates a new spectrum in the Global list.  !!
• Fit the strongest spectral line in SN1987A using a variety of functions: in the SPLAT 

plot window choose !  , this opens the spectral lines fitting window; select the 
types of fits you want to perform (Gaussian, Lorentzian, Voigt), select the type of 
Background (either a Constant, Polynomial, or a loaded background spectrum), 
Add the coordinate range of the line: see the fitting parameters for the different 
profiles in the lower part of the window. You can save the fit results via File → Save 
line fits. !

• Try to find line identifiers via Options → Line identifiers e.g. “SDSS_reflines” !
• Print the spectra and fits of your choice as ps or jpeg.  

http://star-www.dur.ac.uk/~pdraper/splat/splat-vo/
http://star-www.dur.ac.uk/~pdraper/splat/splat-vo/
http://www.star.bris.ac.uk/~mbt/topcat/
http://star-www.dur.ac.uk/~pdraper/splat/splat-vo/
http://star-www.dur.ac.uk/~pdraper/splat/splat-vo/
http://star-www.dur.ac.uk/~pdraper/splat/splat-vo/

